php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73664 Unable to load module on PHP 7.1.0
Submitted: 2016-12-06 03:50 UTC Modified: 2016-12-06 18:13 UTC
From: js at hurdlerate dot com Assigned: cmb (profile)
Status: Not a bug Package: Dynamic loading
PHP Version: 7.1.0 OS: Windows Server 2016
Private report: No CVE-ID: None
 [2016-12-06 03:50 UTC] js at hurdlerate dot com
Description:
------------
Attempting to load php_oauth.dll simply results in 

PHP Startup: Unable to load dynamic library 'c:\\PHP\\ext\\php_oauth.dll' - The specified module could not be found.\r\n in Unknown on line 0

on Apache 2.4 on Windows with PHP 7.1.0. ext/hash and ext/pcre dependencies are satisfied. A quick dependency check shows php_oauth.dll referencing php7.dll, which is not a file included with VC14 x86 Non Thread Safe PHP downloads. Renaming php7apache2_4.dll to php7.dll changes the error to:

PHP Startup: Unable to load dynamic library 'c:\\PHP\\ext\\php_oauth.dll' - The specified procedure could not be found.\r\n in Unknown on line 0

What is the extra dependency and how can I satisfy it?




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-06 15:00 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2016-12-06 15:00 UTC] cmb@php.net
php7.dll is supposed to be contained in all non thread safe Windows binary distributions. However, you're using Apache, so you want to use a thread safe PHP which contains php7ts.dll instead. Make sure to use a thread safe php_oauth.dll as well.
 [2016-12-06 18:03 UTC] js at hurdlerate dot com
-Status: Feedback +Status: Closed
 [2016-12-06 18:03 UTC] js at hurdlerate dot com
Awesome, not sure why I was certain I was on the non-thread safe version but that fixed it. Thank you.
 [2016-12-06 18:13 UTC] cmb@php.net
-Status: Closed +Status: Not a bug -Package: oauth +Package: Dynamic loading
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 18:01:29 2024 UTC