php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #73519 Confusing|Contradicting version requirements in Online Documentation
Submitted: 2016-11-15 00:12 UTC Modified: 2016-11-15 05:02 UTC
From: BowlingAddict at gmail dot com Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: Irrelevant OS: not applicable
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: BowlingAddict at gmail dot com
New email:
PHP Version: OS:

 

 [2016-11-15 00:12 UTC] BowlingAddict at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/mysqli.begin-transaction
---
Page header states requirements as: (PHP 5 >= 5.5.0, PHP 7)
Page body states 'Begins a transaction. Requires MySQL 5.6 and above'



Test script:
---------------
N/A

Expected result:
----------------
Assuming this is simply confusing, not contradicting. By that I mean I'm assuming that object-oriented approach requires version 5.5.0+ and the procedural approach requires version 5.6.0+

Would suggest if that is the case, you add parallel requirements verbiage in each section for clarity.

If that is not the case, and version 5.6.0+ is required for both approaches, fix the requirement at the top of the document.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-11-15 05:02 UTC] requinix@php.net
-Status: Open +Status: Not a bug -Package: Documentation problem +Package: MySQLi related
 [2016-11-15 05:02 UTC] requinix@php.net
As with every other page that shows an object-oriented and a procedural version, the description underneath the two applies to both. They do, and in fact are, the same thing, and since nothing else on the page suggests that the two are available in different versions of PHP then the "PHP 5 >= 5.5.0" is also true for both.
"MySQL 5.6 and above" means you have to be running version 5.6 or later of MySQL, as in MySQL the database management system. On a related note, PHP does not have an "InnoDB engine".
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 19 21:03:42 2021 UTC