|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #73519 Confusing|Contradicting version requirements in Online Documentation
Submitted: 2016-11-15 00:12 UTC Modified: 2016-11-15 05:02 UTC
From: BowlingAddict at gmail dot com Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: Irrelevant OS: not applicable
Private report: No CVE-ID: None
 [2016-11-15 00:12 UTC] BowlingAddict at gmail dot com
From manual page:
Page header states requirements as: (PHP 5 >= 5.5.0, PHP 7)
Page body states 'Begins a transaction. Requires MySQL 5.6 and above'

Test script:

Expected result:
Assuming this is simply confusing, not contradicting. By that I mean I'm assuming that object-oriented approach requires version 5.5.0+ and the procedural approach requires version 5.6.0+

Would suggest if that is the case, you add parallel requirements verbiage in each section for clarity.

If that is not the case, and version 5.6.0+ is required for both approaches, fix the requirement at the top of the document.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2016-11-15 05:02 UTC]
-Status: Open +Status: Not a bug -Package: Documentation problem +Package: MySQLi related
 [2016-11-15 05:02 UTC]
As with every other page that shows an object-oriented and a procedural version, the description underneath the two applies to both. They do, and in fact are, the same thing, and since nothing else on the page suggests that the two are available in different versions of PHP then the "PHP 5 >= 5.5.0" is also true for both.
"MySQL 5.6 and above" means you have to be running version 5.6 or later of MySQL, as in MySQL the database management system. On a related note, PHP does not have an "InnoDB engine".
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Nov 26 12:03:57 2022 UTC