php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73512 Fails to find firebird headers as don't use fb_config output
Submitted: 2016-11-14 06:18 UTC Modified: 2016-11-16 10:44 UTC
From: remi@php.net Assigned: remi
Status: Closed Package: InterBase related
PHP Version: 7.1.0RC6 OS: Fedora 26
Private report: No CVE-ID:
 [2016-11-14 06:18 UTC] remi@php.net
Description:
------------
It seems we cannot build anymore interbase and pdo_firebird against firebird 3.x

checking for Firebird support... yes, shared
checking for isc_detach_database in -lfbclient... no
checking for isc_detach_database in -lgds... no
checking for isc_detach_database in -lib_util... no
configure: error: libfbclient, libgds or libib_util not found! Check config.log for more information.



Patches

use-fb-config.patch (last revision 2016-11-14 12:41 UTC) by remi@php.net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-11-14 08:07 UTC] krakjoe@php.net
Can we get some more information:

krakjoe@fiji:/usr/src/php-src$ /opt/firebird/bin/fb_config --version
3.0.1.32609-0.amd64
krakjoe@fiji:/usr/src/php-src$ sapi/cli/php -nm
[PHP Modules]
...
PDO
PDO_Firebird
...

krakjoe@fiji:/usr/src/php-src$ sapi/cli/php -nv
PHP 7.2.0-dev (cli) (built: Nov 13 2016 21:41:50) ( ZTS DEBUG )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.1.0-dev, Copyright (c) 1998-2016 Zend Technologies
 [2016-11-14 11:33 UTC] remi@php.net
# fb_config --cflags
-I/usr/include/firebird

# fb_config --libs
-L/usr/lib64 -lfbclient

# fb_config --version
3.0.1.32609-0.amd64

I'm still investigating (it seems libfbclient.so is missing...)
 [2016-11-14 12:03 UTC] remi@php.net
BTW, I think we have an issue with config.m4 which does not use fb_config output.

And hard-coded values are not (always) correct: (see previous comment)

  if test "$PHP_INTERBASE" = "yes"; then
    IBASE_INCDIR=/opt/firebird/include
    IBASE_LIBDIR=/opt/firebird/lib
  else
    IBASE_INCDIR=$PHP_INTERBASE/include
    IBASE_LIBDIR=$PHP_INTERBASE/$PHP_LIBDIR
  fi
 [2016-11-14 12:41 UTC] remi@php.net
The following patch has been added/updated:

Patch Name: use-fb-config.patch
Revision:   1479127287
URL:        https://bugs.php.net/patch-display.php?bug=73512&patch=use-fb-config.patch&revision=1479127287
 [2016-11-14 12:42 UTC] remi@php.net
@Joe: would you have time to review attached patch ?
(I'd like to apply it 7.1 before 7.1.0 GA)
 [2016-11-14 14:54 UTC] remi@php.net
-Summary: Compatibility with Firebird 3 +Summary: Fails to find firebird headers as don't use fb_config output
 [2016-11-14 14:54 UTC] remi@php.net
-Assigned To: +Assigned To: remi
 [2016-11-16 09:47 UTC] remi@php.net
Automatic comment on behalf of remi
Revision: http://git.php.net/?p=php-src.git;a=commit;h=397bedcc7c3545510a22b7db8dc6444e0a05b085
Log: Fixed bug #73512 Fails to find firebird headers
 [2016-11-16 09:47 UTC] remi@php.net
-Status: Assigned +Status: Closed
 [2016-11-16 10:44 UTC] krakjoe@php.net
The stream of information coming from bugsnet is too fast to make sense of a lot of the time ... I missed that request for review.

Next time ping me direct on irc or twitter or something ;)
 [2016-11-22 13:14 UTC] krakjoe@php.net
Automatic comment on behalf of remi
Revision: http://git.php.net/?p=php-src.git;a=commit;h=397bedcc7c3545510a22b7db8dc6444e0a05b085
Log: Fixed bug #73512 Fails to find firebird headers
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Wed Feb 22 15:01:37 2017 UTC