php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73375 In window 2016 server few dll are failing to load.
Submitted: 2016-10-23 05:03 UTC Modified: 2016-10-23 07:07 UTC
From: ravi at theglobalsolutions dot net Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 7.0.12 OS: Windows 2016 server
Private report: No CVE-ID: None
 [2016-10-23 05:03 UTC] ravi at theglobalsolutions dot net
Description:
------------
The problem happens only on windows 2016 when integrated with Apache. It works fine with Windows 2012 servers. The following dll fail to load while loading from apache.

PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\PHP\\ext\\php_curl.dll' 
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\PHP\\ext\\php_intl.dll' 
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\PHP\\ext\\php_pdo_pgsql.dll' 
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\PHP\\ext\\php_pgsql.dll' 

Test script:
---------------
Install apache webserver. Enable PHP in apache. Start the apache server it will fail to load the above dll. I am also filing a ticket in Apache. I am not sure which side has the problem so filing in both location.

Expected result:
----------------
All the dll needs to be loaded for the Apache and php to work together.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-10-23 05:29 UTC] ravi at theglobalsolutions dot net
-Status: Open +Status: Closed
 [2016-10-23 05:29 UTC] ravi at theglobalsolutions dot net
Sorry , was excited to report a bug in 2016. After doing more work i found the problem to be an environment variable setting. Php 7.0.12 now works fine in 2016.
 [2016-10-23 07:07 UTC] requinix@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Thu Sep 28 09:01:24 2023 UTC