php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73328 Disabling entity loading breaks XMLReader
Submitted: 2016-10-17 10:33 UTC Modified: 2020-08-31 16:00 UTC
Votes:10
Avg. Score:4.5 ± 0.7
Reproduced:8 of 8 (100.0%)
Same Version:3 (37.5%)
Same OS:5 (62.5%)
From: d dot takken at xs4all dot nl Assigned: cmb (profile)
Status: Duplicate Package: XML Reader
PHP Version: 7.0.12 OS: Linux
Private report: No CVE-ID: None
 [2016-10-17 10:33 UTC] d dot takken at xs4all dot nl
Description:
------------
When entity loading is disabled using libxml_disable_entity_loader(), XMLReader refuses to load XML data using its open() method.


Test script:
---------------
<?php

libxml_disable_entity_loader();

$reader = new XMLReader();
$reader->open('php://stdin');


Expected result:
----------------
The URL provided to open() is successfully opened.

Actual result:
--------------
A warning is generated and the URL is not opened.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-10-17 13:32 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2016-10-17 13:32 UTC] cmb@php.net
Related to bug #62577.
 [2020-08-31 16:00 UTC] cmb@php.net
-Status: Verified +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2020-08-31 16:00 UTC] cmb@php.net
Well, actually a duplicate of #62577.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 29 15:01:25 2020 UTC