php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73077 php compatibility: mb_strpos() [offset warning]
Submitted: 2016-09-14 01:30 UTC Modified: 2016-09-14 01:33 UTC
From: lars at moelleken dot org Assigned: cmb (profile)
Status: Duplicate Package: mbstring related
PHP Version: 7.1.0RC1 OS: Ubuntu 12.04.5 LTS
Private report: No CVE-ID: None
 [2016-09-14 01:30 UTC] lars at moelleken dot org
Description:
------------
"mb_strpos()" is not compatible with old PHP versions, because it dons't trigger a warning anymore "Offset not contained in string"?!

-> https://3v4l.org/o1YNG

Test script:
---------------
var_dump(mb_strpos('abc', 'a', -1));

Expected result:
----------------
Warning: mb_strpos(): Offset not contained in string in /in/o1YNG on line 3
bool(false)

Actual result:
--------------
bool(false)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-09-14 01:33 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2016-09-14 01:33 UTC] cmb@php.net
Duplicate of bug #73076.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 17:03:36 2021 UTC