php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72914 Error parsing EXIF data - IFD data bad offset: 0xFFFFFD32 length 0x1EC2
Submitted: 2016-08-21 20:16 UTC Modified: 2016-08-22 06:36 UTC
From: sunkan+bugs dot gnu at zappa dot cx Assigned:
Status: Duplicate Package: EXIF related
PHP Version: 5.6.25 OS: Linux
Private report: No CVE-ID:
 [2016-08-21 20:16 UTC] sunkan+bugs dot gnu at zappa dot cx
Description:
------------
Thumbnails from my Canon 100D camera can no longer be extracted from the EXIF data.

The test script will only output an error when using PHP 5.6.24 or 5.6.25:
With PHP 5.6.23 it is working (as it always has been for me) and EXIF data including thumbnail is being output.


Test script:
---------------
print_r( exif_read_data( "/tmp/IMG_5888_small.JPG", "THUMBNAIL" ) );

Expected result:
----------------
Output EXIF data with no error

Actual result:
--------------
This warning is being output and no EXIF data (if requiring the thumbnail or using another function to extract the thumbnail):

Warning: exif_read_data(IMG_5888_small.JPG): IFD data bad offset: 0xFFFFFD32 length 0x1EC2 in /tmp/exif.php on line 2


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-08-21 20:22 UTC] sunkan+bugs dot gnu at zappa dot cx
Test image file can be downloaded here (resized from original with GIMP, but still fails like the original file):

https://zappa.cx/~sunkan/IMG_5888_small.JPG
 [2016-08-22 05:42 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2016-08-22 05:42 UTC] requinix@php.net
Duplicate of bug #72819, which itself is likely a duplicate of bug #72735
 [2016-08-22 06:06 UTC] sunkan+bugs dot gnu at zappa dot cx
Well bug #72735 is closed and bug #72819 is suspended and assumed to be no issue due to no feedback.

What bug will be worked on if all three are the same bug?
Can my bug be used as feedback on #72819 so work continues there maybe?
 [2016-08-22 06:33 UTC] requinix@php.net
72819 is still open. Don't worry, your bug report isn't being ignored.
 [2016-08-22 06:36 UTC] cmb@php.net
> Can my bug be used as feedback on #72819 so work continues there
> maybe?

I have opened that ticket again.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Jul 23 16:01:35 2017 UTC