php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7288 Functions checkdnsrr() and getmxrr() not working
Submitted: 2000-10-17 12:42 UTC Modified: 2001-05-14 14:37 UTC
From: andy dot hoffman at bms dot com Assigned:
Status: Closed Package: Network related
PHP Version: 4.0.3 OS: WinNT4.0 SP5
Private report: No CVE-ID: None
 [2000-10-17 12:42 UTC] andy dot hoffman at bms dot com
As reported in bug id# 5311, same problems under NT4 with PHP4.0.3 (www.php4win.de compilation).

This is to confirm that the problems seen with checkdnsrr() and getmxrr() are not specific only to Win2K, but to other Win32 systems as well.  Perhaps this is a problem with how Win32s DNS lookup is structured as opposed to Unix/Linux flavors?  Is there any additional configuration which is necessary for Win32 DNS lookups using these functions?

Whichever the solutions, checkdnsrr() and getmxrr() currently never complete a successful DNS lookup, while other DNS functions, such as gethostbyaddr() or gethostbyname() work correctly (returning valid IP addresses and host names).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-18 22:20 UTC] sniper@php.net
Duplicate of #5311
 [2001-05-14 14:37 UTC] jmoore@php.net
THey now give the correct warning under WIn32 due to a lack of res_search in bindlib_w32 they are currently unsupported under win32 until someone implements them. For now it returns the correct "Is not implemented in this build" error.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 20 21:01:23 2020 UTC