php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #72815 zend_get_parameters_ex() is deprecated
Submitted: 2016-08-11 14:28 UTC Modified: 2016-08-12 00:27 UTC
From: cmb@php.net Assigned: cmb (profile)
Status: Closed Package: dbase (PECL)
PHP Version: Irrelevant OS: *
Private report: No CVE-ID: None
 [2016-08-11 14:28 UTC] cmb@php.net
Description:
------------
The dbase extension uses zend_get_parameters_ex() which is
deprecated as of PHP 5.3. A future proof alternative should be
used instead.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-08-11 14:28 UTC] cmb@php.net
-Assigned To: +Assigned To: cmb
 [2016-08-11 23:29 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&revision=339861
Log: Fix #72815: zend_get_parameters_ex() is deprecated

We replace it with zend_parse_parameters() accepting zvals only, for now.
 [2016-08-11 23:35 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&revision=339862
Log: Merged revision(s) 339860-339861 from pecl/dbase/branches/dbase-5.2:

Fix #72815: zend_get_parameters_ex() is deprecated

We replace it with zend_parse_parameters() accepting zvals only, for now.
 [2016-08-12 00:27 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Oct 26 08:01:22 2020 UTC