php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7270 Installing with Apache 1.3.14 gives 400 response
Submitted: 2000-10-17 01:55 UTC Modified: 2000-11-19 12:23 UTC
From: yusufg at outblaze dot com Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0 Latest CVS (17/10/2000) OS: Linux 2.2.9
Private report: No CVE-ID: None
 [2000-10-17 01:55 UTC] yusufg at outblaze dot com
Hi, I am facing this very strange problem
   
I had Apache 1.3.12 running with PHP out of CVS and compiled with the
following configuration
  
  
  
#! /bin/sh
# Generated automatically by configure.
# Run this file to recreate the current configuration.
# This directory was configured as follows,
# 
  
CFLAGS=-O2 ../php4/configure  \
--with-apache=../apache_1.3.12 \
--prefix=/usr/local/site/php \
--with-db2=/usr/local/site/BerkeleyDB \
--with-ldap=/usr/local/site/ldap \
--with-gd=/usr/local/site/gd \
--with-mhash \
--with-mcrypt \
--enable-calendar \
--enable-track-vars \
--enable-magic-quotes \
--enable-debug \
--with-config-file-path=/usr/local/site

Everything worked smoothly, Now, when Apache 1.3.14 came out I changed
the configure line to point to apache_1.3.14 and recompiled and
installed everything.

When I request for a page, I get a response from the server that the
client made a bad request. I am kinda stumped how this would occur.
Anything I can do to provide more details


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-17 06:02 UTC] sniper@php.net
What does the error_log say?
And doing ./cvsclean ; ./buildconf might be a good thing to do before
reconfiguring and compiling. (make clean after configure!)

--Jani
 [2000-11-19 12:23 UTC] stas@php.net
no feedback, not enough info, old version - closing.
Please reopen with additional info if it stil happens.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 23 18:01:26 2019 UTC