php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72654 only the first folder of include_path is included
Submitted: 2016-07-22 20:39 UTC Modified: 2016-07-23 01:18 UTC
From: divinity76 at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 7.0Git-2016-07-22 (Git) OS: windows 10 x64
Private report: No CVE-ID: None
 [2016-07-22 20:39 UTC] divinity76 at gmail dot com
Description:
------------
only the first folder of include_path is included.

when you have include_path=C:\xampp\php\PEAR;C:\xampp\php\includes; only the PEAR folder is included, but if you have include_path=C:\xampp\php\includes;C:\xampp\php\PEAR; , only the includes folder is included.

full phpinfo(): http://paste.debian.net/784129/
php.ini: include_path=C:\xampp\php\includes;C:\xampp\php\PEAR;


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-07-22 21:40 UTC] divinity76 at gmail dot com
-Status: Open +Status: Closed -Package: PHP options/info functions +Package: *Configuration Issues
 [2016-07-22 21:40 UTC] divinity76 at gmail dot com
Turns out its just a configuration issue, i'm not using double quotes, which fixes the issue (and for the record, neither is xampp's php.ini template. but that should be reported elsewhere)
 [2016-07-23 01:18 UTC] requinix@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 21 16:03:35 2022 UTC