php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72624 Bug 64353 is not resolved in PHP7.0.8
Submitted: 2016-07-19 20:30 UTC Modified: 2017-08-14 13:39 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: peterlebrun at gmail dot com Assigned: dmitry (profile)
Status: Not a bug Package: optimizer (PECL)
PHP Version: 7.0.8 OS: CentOS7
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: peterlebrun at gmail dot com
New email:
PHP Version: OS:

 

 [2016-07-19 20:30 UTC] peterlebrun at gmail dot com
Description:
------------
Bug https://bugs.php.net/bug.php?id=64353 appears to be an issue in PHP7.  We are able to reproduce it with the same script in the original bug report.

Test script:
---------------
See original bug report.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-07-23 11:36 UTC] kalle@php.net
-Status: Open +Status: Assigned -Package: *General Issues +Package: optimizer -Assigned To: +Assigned To: dmitry
 [2017-07-23 11:36 UTC] kalle@php.net
Assigning to Dmitry who fixed the original bug, perhaps a missing merge(?)
 [2017-08-14 13:39 UTC] dmitry@php.net
-Status: Assigned +Status: Not a bug
 [2017-08-14 13:39 UTC] dmitry@php.net
PHP 7 behaves in almost the same way as PHP 5.6.
Both don't produce "Class 'ArrayObject' not found" fatal error.
Both produce another fatal error, because of impossibility to redeclare class "Test", but this is a problem of the original test script.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 02:01:23 2020 UTC