php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72607 Wrong content-encoding on response
Submitted: 2016-07-17 12:23 UTC Modified: 2021-03-23 16:48 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: masood dot 63 at gmail dot com Assigned: cmb (profile)
Status: Wont fix Package: SOAP related
PHP Version: 5.6Git-2016-07-17 (snap) OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2016-07-17 12:23 UTC] masood dot 63 at gmail dot com
Description:
------------
in SoapCleint when response has wrong content-encoding value, a SoapFault Exception occurring with "Unknown Content-Encoding" message. its better to developer can ignore encoding on response.
for example Content-Encoding was set as "text/xml; charset=1256"
instead of setting by "gzip" or etc. 
this is a mistake on developing server-side web service but cause to client side exception.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-03-23 16:48 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: cmb
 [2021-03-23 16:48 UTC] cmb@php.net
I don't think that ignoring a Content-Type header makes sense,
because if the payload is actually compressed, it would let the
XML parser fail in an arbitrary way.

> this is a mistake on developing server-side web service

Indeed, and it shouldn't be hard to fix that.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 22:03:36 2021 UTC