php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #72539 MongoDB stream context only applies to the legacy mongo extension
Submitted: 2016-07-03 16:00 UTC Modified: 2016-07-03 17:11 UTC
From: fgm at osinet dot fr Assigned: cmb (profile)
Status: Not a bug Package: mongodb (PECL)
PHP Version: 7.0.8 OS: n.a.
Private report: No CVE-ID: None
 [2016-07-03 16:00 UTC] fgm at osinet dot fr
Description:
------------
---
From manual page: http://www.php.net/mongo.context
---

Nothing in the page mentions this is only available for the legacy mongo extension and not for the newer mongodb extension.

Indeed, since the mongodb extension also uses a stream context, one would expect that this would be available, but it has been repeatedly rejected by MongoDB Inc.:

* https://jira.mongodb.org/browse/PHPLIB-30 : won't fix
* https://jira.mongodb.org/browse/PHPLIB-38 : won't fix
* https://github.com/mongodb/mongo-c-driver/pull/80 : closed

So that page should include a mention about this lack of support to avoid users losing time and believing this is a code bug.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-07-03 17:11 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2016-07-03 17:11 UTC] cmb@php.net
> http://www.php.net/mongo.context

This is part of the "MongoDB driver (legacy)" book[1]. Information
about the "MongoDB driver" is available in another book[2]. If
you're landing somewhere in the middle of book, refer to the
breadcrumb navigation (immediately below the navigation bar) to
see where you are.

[1] <http://php.net/manual/en/book.mongo.php>
[2] <http://php.net/manual/en/set.mongodb.php>
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 22 16:01:24 2020 UTC