php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72497 SoapClient does not generate exceptions.
Submitted: 2016-06-26 18:37 UTC Modified: 2016-06-26 21:10 UTC
From: liti_007 at yahoo dot com dot br Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 7.0.8 OS: Ubuntu Server 14.04.4
Private report: No CVE-ID: None
 [2016-06-26 18:37 UTC] liti_007 at yahoo dot com dot br
Description:
------------
Apache 503 Service Unavailable when running the script.

Test script:
---------------
try{
	$soap =  new SoapClient($url, [
		'trace' => 1,
		'exceptions' => 1,
		'style' => SOAP_DOCUMENT,
		'use' => SOAP_LITERAL,
		'soap_version' => SOAP_1_1,
		'encoding' => 'UTF-8',
		'stream_context' => stream_context_create($stramOptions)
	]);
	
	$return = $soap->solicitaEtiquetas($parametros); // <-- generated exception here.
	
	
}catch (Exception $e){
	echo $e->getMessage();
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-26 19:16 UTC] liti_007 at yahoo dot com dot br
-Status: Open +Status: Closed
 [2016-06-26 19:16 UTC] liti_007 at yahoo dot com dot br
Error in my code.
 [2016-06-26 21:10 UTC] requinix@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 20 19:03:32 2021 UTC