php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #7243 upload_tmp_dir does not work in safe_mode
Submitted: 2000-10-16 10:43 UTC Modified: 2001-06-12 04:01 UTC
From: wouter at widexs dot nl Assigned:
Status: Duplicate Package: Feature/Change Request
PHP Version: 4.0.3pl1 OS: RedHat 6.2
Private report: No CVE-ID: None
 [2000-10-16 10:43 UTC] wouter at widexs dot nl
We upgraded PHP 4.0.0 to PHP 4.0.3 , cause of the bug fixes.
We use safe_mode, and have set the following options :

safe_mode               =       On
safe_mode_exec_dir      =       .

;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;
file_uploads = On       ; Whether to allow HTTP file uploads
upload_tmp_dir = /opt/guide     ; temporary directory for HTTP uploaded files (will use system default if not specified)
upload_max_filesize = 2M        ; Maximum allowed size for uploaded files


It always worked [we added the file_uploads, since it didn't work] 

The problem is, the scripts always try to write to /tmp, insted of upload_tmp_dir

This is a BIG problem for us (Hosting Provider). Please fix this ;)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-16 15:56 UTC] wouter at widexs dot nl
I tested it on alot of servers we have, and only _one_ is working with the correct upload_tmp_dir as set in /usr/local/lib/php.ini

The httpd has exact the same size as the other ones, so that shouldn't make any difference. 

This is exactly the same problem as described at http://bugs.php.net/bugs.php?id=6875

It also happens @ php 4.0.3pl1 (with apache 1.3.14) and on other OS'es, like slackware 7.1.0


 [2000-10-30 11:20 UTC] sniper@php.net
dup of #6875
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC