php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72417 Empty string causes a syntax error
Submitted: 2016-06-15 15:55 UTC Modified: 2016-06-15 16:59 UTC
From: jonathan at spoonity dot com Assigned:
Status: Not a bug Package: JSON related
PHP Version: 7.0.7 OS: CentOS Linux release 7.2.1511
Private report: No CVE-ID: None
 [2016-06-15 15:55 UTC] jonathan at spoonity dot com
Description:
------------
Prior to PHP 7, the behaviour of an empty string when doing a json_decode() would not cause any error to occur, now with PHP 7 it causes a syntax error to occur.

Test script:
---------------
json_decode("");

if (json_last_error() > 0) {
    echo sprintf("%s (%d)\n", json_last_error_msg(), json_last_error());
}

Expected result:
----------------
No error returned

Actual result:
--------------
Error returned; Syntax error (4)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-15 16:59 UTC] nikic@php.net
-Status: Open +Status: Not a bug
 [2016-06-15 16:59 UTC] nikic@php.net
This is an intentional change. An empty string is not valid JSON.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 15 23:01:27 2019 UTC