php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72327 constructor failed on new instance
Submitted: 2016-06-03 10:52 UTC Modified: 2016-06-03 13:07 UTC
From: david dot gagnaire at doughi dot fr Assigned: cmb (profile)
Status: Not a bug Package: intl (PECL)
PHP Version: 7.0.7 OS: Windows
Private report: No CVE-ID: None
 [2016-06-03 10:52 UTC] david dot gagnaire at doughi dot fr
Description:
------------
Hi,

I'm using php7 RC7 compiled here https://www.apachelounge.com/viewtopic.php?t=6617 with intl ext activated.

On simple new NumberFormatter instance every time i have this exception

IntlException Constructor failed

Test script:
---------------
$formatter = new \NumberFormatter('fr_FR', \NumberFormatter::CURRENCY);


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-03 12:08 UTC] cmb@php.net
-Status: Open +Status: Feedback
 [2016-06-03 12:08 UTC] cmb@php.net
I can't reproduce this issue, neither on Windows 10 with the
official PHP 7.0.7 VC14 x64 Non Thread Safe (2016-May-25
23:02:13), nor on 3v4l.org, see <https://3v4l.org/PRLMB>.

You said you have tested PHP 7.0.7RC7 – did you mean RC1? Anyhow,
please make sure to test with PHP 7.0.7 (GA, not any RC), as the
issue may have been solved in the meantime.
 [2016-06-03 12:43 UTC] david dot gagnaire at doughi dot fr
Yes sure, version used is RC1 on 7.0.7

this one https://phpdev.toolsforresearch.com/php-7.0.7RC1-nts-Win32-VC14-x64.zip
because all extension i used are included.

i'll try with official and i come back

thanks for answer
 [2016-06-03 12:49 UTC] david dot gagnaire at doughi dot fr
it's ok but strange

i take official http://windows.php.net/downloads/releases/php-7.0.7-nts-Win32-VC14-x64.zip php_intl.dll from this package with all ixx57.dll

and contains all ixx57.dll not included in this one https://phpdev.toolsforresearch.com/php-7.0.7RC1-nts-Win32-VC14-x64.zip which contains ixx56.dll why this difference ? what are this dll used for ?

you can close this entry but if you have any answer for me don't hesitate ;)
 [2016-06-03 13:07 UTC] cmb@php.net
-Status: Feedback +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2016-06-03 13:07 UTC] cmb@php.net
I assume you are referring to the icu*57.dlls in the root of the
download: these are the ICU[1] libraries required for the intl
extension[2]. Apparently, ApacheLounge ships older versions of
these libraries (the official PHP 7.0.7RC1 already shipped with
57). That *might* explain the misbehavior.

[1] <http://site.icu-project.org/>
[2] <http://php.net/manual/en/intl.requirements.php>
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Mar 23 14:01:26 2019 UTC