php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72110 Strange URL behaviors
Submitted: 2016-04-27 05:00 UTC Modified: 2019-05-21 22:25 UTC
From: philip@php.net Assigned:
Status: Open Package: Systems problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2016-04-27 05:00 UTC] philip@php.net
Description:
------------
This page:

  http://php.net/manual/en/tutorial.whatsnext.php

Contains a link to this:

  http://talks.php.net/

However that site is failing. Strangely, for good measure I tried SSL:

  https://talks.php.net/

That ends up showing contents from people.php.net. Odd. Also odd, looking for alternatives I tried:

  http://conf.php.net/
  http://pres.php.net/

And those end up showing contents from gtk.php.net. Odd.

So, lots of different bugs here, it seems.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-04-27 16:51 UTC] bjori@php.net
- people.php.net is the default host for https on that server
- gtk.php.net is the default host for http on that server
- conf and pres is dead
- http://talks.php.net is the correct url (not https), it just got broken very recently when someone updated their presentation
 [2016-04-27 17:17 UTC] philip@php.net
I won't be satisfied until kittens.php.net shows people.php.net content! 

Otherwise, why show unrelated content like this? Having https://talks.php.net/ and http://talks.php.net/ showing unrelated content feels wrong. Having old subdomains show default (unrelated) content also feels wrong.

Lastly, talks.php.net should not fail if someone uploads an invalid presentation.
 [2016-04-27 23:03 UTC] bjori@php.net
I didn't mean to say it should be this way, merely meant to cast a light on the seemingly random behavior.
 [2016-05-06 11:27 UTC] marc at infomarc dot info
Hi,
as of today, http://talks.php.net is still failing : 

XML_Parser: Not well-formed (invalid token) at XML input line 1:1
 [2016-05-06 21:30 UTC] philip@php.net
The talks.php.net issue is now fixed, see:

http://git.php.net/?p=web/pres2.git;h=cd2807b0842ea2a23d13a1eb5bd43c2b0fd517da

However, the strange domain behavior (old subdomains showing unrelated content) remains.
 [2019-05-21 22:25 UTC] petk@php.net
-Package: Website problem +Package: Systems problem
 [2019-05-21 22:25 UTC] petk@php.net
Yes, the old subdomains can be now removed and/or redirected to other pages instead... Moving this to systems hoping it will be resolved. So only two links need removal:

  http://conf.php.net/
  http://pres.php.net/

and one need proper redirection from http to https:


  talks.php.net

Thank you for reporting this issue.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jun 16 19:01:27 2019 UTC