php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72103 pdo_mysql fails to build with php v7.0.5
Submitted: 2016-04-25 17:58 UTC Modified: 2016-10-11 12:46 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: gencer at gencgiyen dot com Assigned:
Status: Not a bug Package: PDO Core
PHP Version: 7.0.5 OS: Debian 8.3 x64
Private report: No CVE-ID: None
 [2016-04-25 17:58 UTC] gencer at gencgiyen dot com
Description:
------------
When building PHP 7.0.5 with custom config i get pdo_mysql or pdo_pgsql error and cannot make install.

for mysql:
/php/php-7.0.5/ext/pdo_mysql/pdo_mysql.c:68:21: warning: initialization makes pointer from integer without a cast
   pdo_dbh_t * dbh = Z_PDO_DBH_P(zv);
                     ^
Makefile:1459: recipe for target 'ext/pdo_mysql/pdo_mysql.lo' failed
make: *** [ext/pdo_mysql/pdo_mysql.lo] Error 1


and for postgresql:

/php/php-7.0.5/Zend/zend_alloc.h:85:31: note: expected ‘const char *’ but argument is of type ‘int’
 ZEND_API char*  ZEND_FASTCALL _estrndup(const char *s, size_t length ZEND_FILE_LINE_DC ZEND_FILE_LINE_ORIG_DC) ZEND_ATTRIBUTE_MALLOC;
                               ^
Makefile:1457: recipe for target 'ext/pdo_pgsql/pdo_pgsql.lo' failed
make: *** [ext/pdo_pgsql/pdo_pgsql.lo] Error 1

I attached configuration sample on test script area

Notes:
I installed mysql 5.5.x with "apt-get mysql-client mysql-server". I also postgresql 9.5.2 installed. For MySQL, I tried "--with-pdo=x" via x=mysqlnd, x=shared and without x param. None of them is worked.



Test script:
---------------
./configure '--enable-bcmath' '--enable-debug' '--enable-zip' '--with-libdir=lib' '--build=x86_64-linux-gnu' '--target=x86_64-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--enable-gd-native-ttf' '--with-t1lib=/usr' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl=shared' '--with-pcre-regex' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-sockets' '--with-kerberos' '--enable-ucd-snmp-hack' '--enable-shmop' '--enable-calendar' '--with-libxml-dir=/usr' '--enable-libxml' '--with-xmlrpc' '--enable-xml' '--with-system-tzdata' '--with-mhash' '--with-mysql' '--with-gd' '--enable-dom' '--enable-dba' '--with-unixODBC=/usr' '--enable-xmlreader' '--enable-xmlwriter' '--without-sqlite' '--with-sqlite3' '--enable-phar' '--enable-fileinfo' '--enable-json' '--without-pspell' '--disable-wddx' '--disable-sysvmsg' '--disable-sysvshm' '--disable-sysvsem' '--enable-pdo' '--enable-mbstring' '--enable-fastcgi' '--with-mcrypt' '--enable-fpm' '--enable-pcntl' '--with-imap=../imap-2007f' '--with-pdo-mysql=mysqlnd' '--with-imap-ssl' '--with-pgsql=/usr/include/postgresql' '--with-pdo-pgsql=/usr/include/postgresql' '--with-curl=../curl-7.48.0' '--with-mysqli=mysqlnd' '--enable-maintainer-zts'

Expected result:
----------------
make install to be done without error (same as php5x)

Actual result:
--------------
makefile errors for pdo drivers (for each of them)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-10-10 22:29 UTC] adambaratz@php.net
-Status: Open +Status: Feedback
 [2016-10-10 22:29 UTC] adambaratz@php.net
Are you still encountering this issue?
 [2016-10-11 08:15 UTC] gencer at gencgiyen dot com
no. issue fixed earlier. I no longer get such issue anymore.
 [2016-10-11 12:46 UTC] adambaratz@php.net
-Status: Feedback +Status: Not a bug
 [2016-10-11 12:46 UTC] adambaratz@php.net
Thanks! Closing.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jul 13 00:01:25 2020 UTC