php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72001 Solr.dll expects php7.dll
Submitted: 2016-04-11 10:50 UTC Modified: 2016-04-11 13:13 UTC
From: karim at gbv dot de Assigned: omars (profile)
Status: Not a bug Package: solr (PECL)
PHP Version: 7.0.5 OS: Win7 64
Private report: No CVE-ID: None
 [2016-04-11 10:50 UTC] karim at gbv dot de
Description:
------------
Hello !

1) My System: Apache2, php7, 32Bit Version on Windows7, 64 Bit.
(Solr 2.3.0 Extension worked fine by simply adding the library to the php.ini file.)
That does not work anymore for package 2.4.0. Apache2 reports a missing php7.dll. The solr 2.4.0 package is therefore not loaded.

2) Installation instruction is missing. Inside the package the readme.installation is missing. Well, i can't find it.

Thank you for developing this...

Alex


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-04-11 12:55 UTC] omars@php.net
I think you downloaded solr-nts, where you should have downloaded the zts package.
 [2016-04-11 13:13 UTC] omars@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: omars
 [2016-04-11 13:13 UTC] omars@php.net
Not a bug, happened due to mismatching thread safety between php and solr packages.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 09:01:23 2020 UTC