php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71911 Unable to set --enable-debug on building extensions by phpize on Windows
Submitted: 2016-03-29 00:42 UTC Modified: 2016-07-12 11:07 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: y dot uchiyama dot 1015 at gmail dot com Assigned: ab
Status: Closed Package: *Compile Issues
PHP Version: Irrelevant OS: Windows
Private report: No CVE-ID:
 [2016-03-29 00:42 UTC] y dot uchiyama dot 1015 at gmail dot com
Description:
------------
This issue is about phpize on Windows.

When an extension is built using phpize on Windows, the configure script ignores --enable-debug and always build in 'Release' mode. It results compilation error if the targetted PHP is built with --enable-debug because the linker try to link to php7.dll though php7_debug.dll is needed.



Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-07-12 11:07 UTC] ab@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: ab
 [2016-07-12 11:07 UTC] ab@php.net
Merged with 7.0.

Thanks.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Fri Apr 28 23:01:35 2017 UTC