php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71808 Function mb_ereg_replace() undefined in 7.0.4
Submitted: 2016-03-12 06:38 UTC Modified: 2016-03-12 07:02 UTC
From: eacraft13 at gmail dot com Assigned:
Status: Not a bug Package: mbstring related
PHP Version: 7.0.4 OS: Ubuntu 14.04
Private report: No CVE-ID: None
 [2016-03-12 06:38 UTC] eacraft13 at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.mb-ereg-replace
---

mb_ereg_replace is undefined in 7.0.4

$ php --version
PHP 7.0.4-5+deb.sury.org~trusty+1 (cli) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies





Test script:
---------------
<?php

echo mb_ereg_replace('-', ' ', 'new-jersey');

Expected result:
----------------
new jersey

Actual result:
--------------
PHP Fatal error:  Uncaught Error: Call to undefined function mb_ereg_replace() in /home/vagrant/test.php:3
Stack trace:
#0 {main}
  thrown in /home/vagrant/test.php on line 3

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-03-12 06:47 UTC] requinix@php.net
-Status: Open +Status: Feedback -Package: Regexps related +Package: mbstring related
 [2016-03-12 06:47 UTC] requinix@php.net
Do the other mb_* functions exist? Is the extension even installed?
 [2016-03-12 06:56 UTC] eacraft13 at gmail dot com
-Status: Feedback +Status: Open
 [2016-03-12 06:56 UTC] eacraft13 at gmail dot com
No they weren't. My fault. Thanks for the reply.
 [2016-03-12 07:02 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2016-03-12 07:02 UTC] requinix@php.net
.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jan 23 06:03:36 2022 UTC