php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7157 Cannot Suppot both Oracle and Informix
Submitted: 2000-10-12 09:12 UTC Modified: 2001-11-10 12:33 UTC
From: pablot at bancobisel dot com dot ar Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0.3 OS: Solaris 2.7
Private report: No CVE-ID: None
 [2000-10-12 09:12 UTC] pablot at bancobisel dot com dot ar
Using this configure script:

./configure --with-oci8
            --with-informix=/informix 
            --with-mysql=/export/home/local 
            --with-ldap=/export/home/openldap 
            --with-apache=../apache_1.3.12 
            --enable-track-vars 
            --enable-calendar 
            --enable-inline-optimization 
            --enable-trans-sid                    

It?s not possible to make Oracle and Informix support work at the same time. You must either compile Oracle support OR Informix support.

The problem arises when using mod_ssl, it looses the ssl encription channel and the apache log shows:

[Thu Oct 12 09:40:29 2000] [notice] Apache/1.3.12 (Unix) PHP/4.0.3 mod_ssl/2.6.6
 OpenSSL/0.9.5a configured -- resuming normal operations                        
[Thu Oct 12 09:43:27 2000] [notice] child pid 17316 exit signal Segmentation Fault 
(11)                                                        

But the problem also happens without ssl, it has been tested with php 4.0.3 and php 4.0.2, with apache 1.3.9 and apache 1.3.12, so it seems the problem is there from some time ago or it has been there always!!

It also makes no difference it you use OCI8 or Oracle support. It has been tested with Oracle 8.1.5 and Oracle 8.0.5 and the same results.

Just taking out the "--with-oci8" from the configure script makes it work ok, but of course with no Oracle support!!!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-07 19:50 UTC] sniper@php.net
Have you set all the needed environment variables before starting Apache?
See http://www.php.net/manual/ref.oci8.php for more info.

--Jani
 [2001-01-08 08:21 UTC] sniper@php.net
Could you please generate a GDB backtrace of this crash?

--Jani
 [2001-01-08 09:00 UTC] sniper@php.net
Sorry, I forgot to paste this URL:

http://bugs.php.net/bugs-generating-backtrace.php

--Jani
 [2001-02-20 07:41 UTC] sniper@php.net
No feedback, considered fixed. (Always use the web interface to reply!)

--Jani

 [2001-02-22 19:27 UTC] sniper@php.net
User feedback:
-----------
It?s not fixed, but I cannot generate the backtrace.


 [2001-08-03 23:17 UTC] sniper@php.net
Without a backtrace, it's impossible to even
start guessing what might be the cause of this crash.

Suspended until this information is provided.

 [2001-11-10 12:33 UTC] sander@php.net
Let's close this bug.
If you want this fixed, do the following:
-install the latest CVS (or at least 4.0.6)
-generate a backtrace
-post the backtrace here and reopen this report
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 09:06:03 2022 UTC