php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71565 php-5.6.18-Win32-VC11-x86.zip is 64BIT
Submitted: 2016-02-10 13:04 UTC Modified: 2016-02-10 19:29 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: danilo dot giorgi at regione dot toscana dot it Assigned: cmb (profile)
Status: Not a bug Package: Windows Installer
PHP Version: 5.6.18 OS: Windows XP SP3 32BIT
Private report: No CVE-ID: None
 [2016-02-10 13:04 UTC] danilo dot giorgi at regione dot toscana dot it
Description:
------------
The file on php-5.6.18-Win32-VC11-x86.zip  don't is a 32 bit executable (is 64 bit).
When I execute php.exe, I receive the message:
 "php.exe is not a valid Win32 application"


Expected result:
----------------
php.exe is execute

Actual result:
--------------
"php.exe is not a valid Win32 application"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-02-10 13:30 UTC] danilo dot giorgi at regione dot toscana dot it
This problem is also on:
php-5.5.32-Win32-VC11-x86.zip
php-5.5.9-Win32-VC11-x86.zip
php-5.5.9-nts-Win32-VC11-x86.zip

Danilo
 [2016-02-10 19:29 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2016-02-10 19:29 UTC] cmb@php.net
The problem is not that the executable is a 64bit version, but
rather that Windows XP is not supported anymore as of PHP 5.5.0,
see <http://php.net/manual/en/install.windows.php>.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Feb 25 13:01:27 2024 UTC