php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7150 Access violation for php.exe when a php script is called in the browser
Submitted: 2000-10-12 03:53 UTC Modified: 2001-02-20 07:41 UTC
From: benoit dot noss at iaurif dot org Assigned:
Status: Closed Package: Other web server
PHP Version: 4.0.3RC2 OS: Win NT4 SP5, iPlanet web server
Private report: No CVE-ID: None
 [2000-10-12 03:53 UTC] benoit dot noss at iaurif dot org
Tested with the 4.0.3 release.

PHP4.0.3 is working on the command line
      D:\NETSCAPE\SERVER4\docs>test.php
      X-Powered-By: PHP/4.0.3
      Content-type: text/html

      This is a test

The same test.php script called from a browser, with iPlanet web server
and php configured as shell-cgi (this configuration is working with PHP3),
causes php4 (php.exe) generate a Dr Watson log file
====================================
Une exception d'application s'est produite?:
        App?:  (pid=305) in my case pid=305 is php.exe
        Quand?: 10/12/2000 @ 9:17:35.790
====================================

What can be the cause of this error?
Do I have to define a specific open method in the PHP Mime Type?
(actually action=open,application=d:\php4\php.exe)
        Num?ro d'exception?: c0000005 (violation d'acc?s)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-09 14:57 UTC] cynic@php.net
does this happen with 4.0.4?
 [2001-02-20 07:41 UTC] sniper@php.net
No feedback, considered fixed.

--Jani

 [2002-05-10 05:49 UTC] noel dot breton at cnav dot fr
I'am just installing PHP4 as CGI script on Iplanet Web Server 4.1 on NT.
I use the 4.1.1 release and I have the same problem.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 14 21:01:24 2020 UTC