php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #71490 ldap_sort() manpage says nothing of deprecation in PHP 7
Submitted: 2016-02-01 14:47 UTC Modified: 2016-03-10 09:08 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: ben at indietorrent dot org Assigned: mcmic (profile)
Status: Closed Package: LDAP related
PHP Version: 7.0.2 OS: GNU/Linux
Private report: No CVE-ID: None
 [2016-02-01 14:47 UTC] ben at indietorrent dot org
Description:
------------
---
From manual page: http://www.php.net/function.ldap-sort
---

Nowhere on the ldap_sort() manpage is it mentioned that this function is deprecated in PHP 7.

Nor is there any mention of a replacement nor alternative function.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-03-10 09:08 UTC] mcmic@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: mcmic
 [2016-03-10 09:08 UTC] mcmic@php.net
Sorry about this, documentation had been updated but the change was not committed for some reason.
Now the function correctly appears as deprecated since PHP 7.

As for a replacement, there is no drop in replacement since openldap deprecated the ldap_sort function on their side.
You can use any PHP sorting function suiting your needs: http://php.net/manual/en/array.sorting.php
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 02 20:03:58 2022 UTC