php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71470 Leaked 1 hashtable iterators
Submitted: 2016-01-28 00:46 UTC Modified: 2016-02-24 13:14 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: damir dot zelenika at hteronet dot ba Assigned: nikic
Status: Closed Package: *General Issues
PHP Version: 7.0.3 OS: Debian 8.3
Private report: No CVE-ID:
 [2016-01-28 00:46 UTC] damir dot zelenika at hteronet dot ba
Description:
------------
I have just installed php7 on my test server.
For each http request php generates a warning in php error log:
  PHP Warning:  Leaked 1 hashtable iterators in Unknown on line 0
Warning is generated even for simple script as

<?php 

phpinfo()

?>



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-01-28 02:36 UTC] yohgaki@php.net
-Status: Open +Status: Feedback
 [2016-01-28 02:36 UTC] yohgaki@php.net
I think we need loaded extensions. Could you paste output of

print_r(get_loaded_extensions());
 [2016-02-07 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2016-02-16 09:28 UTC] aharvey@php.net
-Status: No Feedback +Status: Open -PHP Version: 7.0.2 +PHP Version: 7.0.3
 [2016-02-16 09:28 UTC] aharvey@php.net
Reopening per nitrotrigger on IRC (who's seeing this on 7.0.3 and will provide their list of extensions).
 [2016-02-16 09:48 UTC] marko at okramlabs dot com
I got same issue by checking today my logs:
PHP log: PHP Warning:Leaked 1 hashtable iterators in Unknown on line 0
Server log: Invalid request (Unexpected EOF)

In server log I'll see that one of my own frameworks causing this in my dev server, I'll see in the log multiple request with same pattern per request.
1. [200]: /
2. [200]: /css/theme.css
3. [200]: /icons/favicon.ico
4. Invalid request (Unexpected EOF)
As you can notice it is light request since it's bare framework with Hello wWorld which has execution time of 6.11 ms.

PHP 7.0.3 (cli) (built: Feb 10 2016 01:50:48) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with Xdebug v2.4.0RC3, Copyright (c) 2002-2015, by Derick Rethans

php -m
[PHP Modules]
bcmath
bz2
calendar
Core
ctype
curl
date
dom
exif
fileinfo
filter
ftp
gd
gettext
gmp
hash
iconv
imap
intl
json
ldap
libxml
mbstring
mcrypt
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
pspell
readline
Reflection
session
SimpleXML
soap
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
tidy
tokenizer
wddx
xdebug
xml
xmlreader
xmlrpc
xmlwriter
xsl
zip
zlib

[Zend Modules]
Xdebug
 [2016-02-16 10:18 UTC] marko at okramlabs dot com
To be noted that bug was originaly reported OS: Debian 8.3 but had same problem on Fedora 23
 [2016-02-16 12:21 UTC] nikic@php.net
Does this also happen if you disable xdebug?
 [2016-02-24 00:56 UTC] marko at okramlabs dot com
@nikic, Yes it does also happen if I disable xdebug.
 [2016-02-24 09:49 UTC] yohgaki@php.net
@marko
I guess you can reproduce the bug by CLI. Could you identify which module is causing this?

Could you post your system information also?
 [2016-02-24 12:53 UTC] marko at okramlabs dot com
My php configuration is same as I posted initially only have disabled xdebug.
Machine is Linux Fedora.23 4.3.5-300.fc23.x86_64 x86_64 GNU/Linux.
I waited with my previous response since I tried to identify it, but the issue is not something which occurs regularly. However a close brother of it is "Invalid request (Unexpected EOF)" since these occur most times together.
So far only thing sure in my case is that this is produced only by Built in Server and haven't spot it while running other web servers. Also none of my CLI applications haven't triggered this. Only bit of consistency I have noticed is that when some of my in-development web app front-ends make requests to some resources as file/css/js/xhr etc which have been (Modified|Do not exist|Are empty files) then I can expect to see "Invalid request (Unexpected EOF)" in Development Servers cli and inconsistently thereafter in logs I can find "Leaked 1 hashtable iterators...". If I can be any help, you need some more information or you have some testsuites I could run on current installation let me know. Otherwise I would recompile my php after few days.
 [2016-02-24 13:10 UTC] nikic@php.net
Automatic comment on behalf of nikic
Revision: http://git.php.net/?p=php-src.git;a=commit;h=d1057cc13971e90ea3e7720dc5c82bbc92c4ad23
Log: Fixed bug #71470
 [2016-02-24 13:10 UTC] nikic@php.net
-Status: Open +Status: Closed
 [2016-02-24 13:14 UTC] nikic@php.net
-Assigned To: +Assigned To: nikic
 [2016-02-24 13:14 UTC] nikic@php.net
I'm not certain if this fix will resolve your issue, but it seems likely. If it doesn't, please reopen this bug.
 [2016-07-20 11:33 UTC] davey@php.net
Automatic comment on behalf of nikic
Revision: http://git.php.net/?p=php-src.git;a=commit;h=d1057cc13971e90ea3e7720dc5c82bbc92c4ad23
Log: Fixed bug #71470
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Apr 30 18:01:35 2017 UTC