php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #71411 PHP 7 support
Submitted: 2016-01-19 09:10 UTC Modified: 2016-01-20 14:30 UTC
From: michal dot lohnisky at seznam dot cz Assigned:
Status: Not a bug Package: PDO DBlib
PHP Version: 7.0.2 OS: Linux
Private report: No CVE-ID: None
 [2016-01-19 09:10 UTC] michal dot lohnisky at seznam dot cz
Description:
------------
Do you plan to add support for PHP 7?

Test script:
---------------
# pecl install pdo_dblib


Actual result:
--------------
pear/PDO_DBLIB requires PHP (version >= 5.0.3, version <= 6.0.0), installed version is 7.0.2
No valid packages found
install failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-01-20 01:18 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2016-01-20 01:18 UTC] rasmus@php.net
That is a pear package which has its own bug tracker at http://pear.php.net/bugs/
If I could move the bug there easily, I would, but the two trackers aren't linked so you will have to re-file it yourself.
 [2016-01-20 09:39 UTC] ken at linux dot ie
pdo_dblib is not a pear package...

https://pear.php.net/search.php?q=pdo&in=packages&x=0&y=0
 [2016-01-20 12:08 UTC] michal dot lohnisky at seznam dot cz
Yes, I know and on https://pecl.php.net/bugs/ I read "If you want to report a bug for a specific package, please go to the package home page" which is https://pecl.php.net/package/PDO_DBLIB . Then I clicked on "Report new bug" which leads to https://bugs.php.net/report.php?package=PDO_DBLIB . And here I am.

So is this right tracker?
 [2016-01-20 14:30 UTC] rasmus@php.net
Ah true, but it is an unmaintained pecl package that last had a release 11 years ago and none of the maintainers from back then are around anymore, so it is unlikely that this will be updated. I suggest you use PDO_ODBC instead.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 26 03:01:26 2019 UTC