php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71406 var_export exports INF as "INF.0"
Submitted: 2016-01-18 13:36 UTC Modified: 2016-01-18 18:55 UTC
From: Oleg dot Stepanischev at tatar dot ru Assigned:
Status: Duplicate Package: Variables related
PHP Version: 7.0.2 OS: Linux
Private report: No CVE-ID: None
 [2016-01-18 13:36 UTC] Oleg dot Stepanischev at tatar dot ru
Description:
------------
// PHP <= 7.0.1:
var_export(INF); // INF

// PHP 7.0.2:
var_export(INF); // INF.0


Test script:
---------------
var_export(INF);

Expected result:
----------------
INF

Actual result:
--------------
INF.0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-01-18 13:44 UTC] Oleg dot Stepanischev at tatar dot ru
-Status: Open +Status: Closed
 [2016-01-18 13:44 UTC] Oleg dot Stepanischev at tatar dot ru
Duplicate of #71314
 [2016-01-18 18:55 UTC] requinix@php.net
-Status: Closed +Status: Duplicate
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Aug 23 14:01:27 2019 UTC