php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71389 precompiled binaries for windows compiled with wrong extension versions
Submitted: 2016-01-16 13:22 UTC Modified: 2016-01-17 19:38 UTC
From: 1000-fists at live dot com Assigned:
Status: Not a bug Package: PECL (PECL)
PHP Version: 5.6.17 OS: windows 7
Private report: No CVE-ID: None
 [2016-01-16 13:22 UTC] 1000-fists at live dot com
Description:
------------
[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: bz2: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: curl: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: com_dotnet: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: fileinfo: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: gd: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: gettext: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: gmp: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: intl: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: imap: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: ldap: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: mbstring: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: exif: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'ext\php_mysql.dll' - The specified module could not be found.

 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: mysqli: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: openssl: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: pdo_mysql: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: pdo_sqlite: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: shmop: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: soap: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: sockets: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: sqlite3: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: xmlrpc: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: xsl: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: bz2: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: curl: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: com_dotnet: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: fileinfo: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: gd: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: gettext: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: gmp: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: intl: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: imap: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: ldap: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: mbstring: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: exif: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'ext\php_mysql.dll' - The specified module could not be found.

 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: mysqli: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: openssl: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: pdo_mysql: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:23 UTC] PHP Warning:  PHP Startup: pdo_sqlite: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:24 UTC] PHP Warning:  PHP Startup: shmop: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:24 UTC] PHP Warning:  PHP Startup: soap: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:24 UTC] PHP Warning:  PHP Startup: sockets: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:24 UTC] PHP Warning:  PHP Startup: sqlite3: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:24 UTC] PHP Warning:  PHP Startup: xmlrpc: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0

[16-Jan-2016 13:18:24 UTC] PHP Warning:  PHP Startup: xsl: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20131226
These options need to match
 in Unknown on line 0



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-01-17 19:38 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2016-01-17 19:38 UTC] ab@php.net
Thanks for the report. In your environment, please be sure the paths for different PHP versions don't interfere. Preferably you also should use an absolute path in extension_dir INI directive.

Thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jul 12 13:01:26 2020 UTC