php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7138 quoted_printable_decode doesn't handle soft line breaks
Submitted: 2000-10-11 12:31 UTC Modified: 2000-11-20 05:12 UTC
From: burton at mailshell dot com Assigned:
Status: Closed Package: Strings related
PHP Version: 4.0.2 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: burton at mailshell dot com
New email:
PHP Version: OS:

 

 [2000-10-11 12:31 UTC] burton at mailshell dot com

quoted_printable_decode does not appear to handle soft line
breaks as defined in RFC 1521.
That is, lines ending with an equal symbol followed by
carriage return and line feed should be replaced by the
empty string


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-18 13:39 UTC] burton at mailshell dot com
--- php-current/functions/quot_print.c.orig     Sat Jan  1 07:31:16 2000
+++ php-current/functions/quot_print.c  Mon Sep 18 17:00:22 2000
@@ -93,10 +93,9 @@
                str[j++] = (_php3_hex2int((int)str[i+1]) << 4 )
                           + _php3_hex2int((int)str[i+2]);
                i += 3;
-       }
-       else if ( str[i] == 13 )
+       } else if ( (str[i] == '=') && str[i+1] && (str[i+1] == 10) )
        {
-               i++;
+               i += 2;
        }
        else
        {



 [2000-11-17 03:41 UTC] kir@php.net
Duplicate of #5321.
 [2000-11-20 05:12 UTC] kir@php.net
Check the latest version on http://snaps.php.net 
or wait until 4.0.4.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 19:01:25 2019 UTC