php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71377 PHP 5.6.16 Program terminated with signal 7, Bus error.
Submitted: 2016-01-14 23:23 UTC Modified: 2017-12-23 11:08 UTC
Votes:8
Avg. Score:4.6 ± 0.7
Reproduced:7 of 7 (100.0%)
Same Version:4 (57.1%)
Same OS:2 (28.6%)
From: oranze at mail dot ru Assigned:
Status: Duplicate Package: FPM related
PHP Version: 5.6Git-2016-01-14 (snap) OS: Centos
Private report: No CVE-ID: None
 [2016-01-14 23:23 UTC] oranze at mail dot ru
Description:
------------
Sometimes php-fpm give back error: Program terminated with signal 7, Bus error.
core dump of process:
(gdb) bt
#0  0x00007f2f56cddf45 in lex_scan ()
#1  0x00007f2f56cfd1c2 in zendlex ()
#2  0x00007f2f56cd6fa6 in zendparse ()
#3  0x00007f2f56cdc7db in compile_file ()
#4  0x00007f2f56d03b3a in dtrace_compile_file ()
#5  0x00007f2f4acdfbfa in phar_compile_file () from /usr/lib64/php/modules/phar.so
#6  0x00007f2f5246cd14 in ?? ()
#7  0x0000000000000000 in ?? ()

Please fix it.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-01-14 23:28 UTC] oranze at mail dot ru
php -m
[PHP Modules]
bcmath
bz2
calendar
Core
ctype
curl
date
dom
ereg
exif
fileinfo
filter
ftp
gd
gettext
gmp
hash
iconv
igbinary
json
libxml
mbstring
mcrypt
memcache
memcached
mhash
mysql
mysqli
openssl
pcntl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
readline
Reflection
session
shmop
SimpleXML
soap
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
tidy
tokenizer
wddx
xml
xmlreader
xmlwriter
xsl
zip
zlib

[Zend Modules]
 [2016-01-18 17:51 UTC] oranze at mail dot ru
php 5.6.16 same error.
 [2016-01-18 17:52 UTC] oranze at mail dot ru
5.6.17 have a same bug, sorry
 [2016-09-06 14:15 UTC] tom dot chris dot hanks at gmail dot com
I've same error :(
 [2017-12-23 11:08 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2017-12-23 11:08 UTC] nikic@php.net
Very likely a duplicate of bug #52752.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jun 24 17:01:25 2019 UTC