php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71315 mailparse required php7 !?
Submitted: 2016-01-08 17:06 UTC Modified: 2016-03-15 04:44 UTC
Votes:4
Avg. Score:4.5 ± 0.9
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:4 (100.0%)
From: jean-luc dot cooke at trustificorp dot com Assigned: seander (profile)
Status: Closed Package: mailparse (PECL)
PHP Version: 5.5.31 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jean-luc dot cooke at trustificorp dot com
New email:
PHP Version: OS:

 

 [2016-01-08 17:06 UTC] jean-luc dot cooke at trustificorp dot com
Description:
------------
Cannot install mailparse via pecl due to it requiring PHP v7.

Way too early to be requiring that.

Test script:
---------------
pecl install mailparse


Expected result:
----------------
success

Actual result:
--------------
pecl/mailparse requires PHP (version >= 7.0.0), installed version is 5.5.30
No valid packages found
install failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-01-09 10:35 UTC] b dot bellec at gmail dot com
I experience the same issue on a Ubuntu 14.04 LTS server (PHP 5.5.9-1ubuntu4.14).

By default pecl seems to install the last version available, which is now mailparse-3.0.0 which indeed requires PHP 7.0.0.
But you can choose a previous version manually:
$ sudo pecl install mailparse-2.1.6

You can check all the releases version on this page:
https://pecl.php.net/package/mailparse
 [2016-03-15 04:43 UTC] seander@php.net
-Assigned To: +Assigned To: seander
 [2016-03-15 04:43 UTC] seander@php.net
Thanks for answering this b.bellec!

I added a note on how to install older versions of mailparse to the PECL page. I need to follow up on getting pecl to install the newest compatible version, and no just bomb out.

thanks
 [2016-03-15 04:44 UTC] seander@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 08 10:01:24 2019 UTC