|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71315 mailparse required php7 !?
Submitted: 2016-01-08 17:06 UTC Modified: 2016-03-15 04:44 UTC
Avg. Score:4.5 ± 0.9
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:4 (100.0%)
From: jean-luc dot cooke at trustificorp dot com Assigned: seander (profile)
Status: Closed Package: mailparse (PECL)
PHP Version: 5.5.31 OS: linux
Private report: No CVE-ID: None
 [2016-01-08 17:06 UTC] jean-luc dot cooke at trustificorp dot com
Cannot install mailparse via pecl due to it requiring PHP v7.

Way too early to be requiring that.

Test script:
pecl install mailparse

Expected result:

Actual result:
pecl/mailparse requires PHP (version >= 7.0.0), installed version is 5.5.30
No valid packages found
install failed


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2016-01-09 10:35 UTC] b dot bellec at gmail dot com
I experience the same issue on a Ubuntu 14.04 LTS server (PHP 5.5.9-1ubuntu4.14).

By default pecl seems to install the last version available, which is now mailparse-3.0.0 which indeed requires PHP 7.0.0.
But you can choose a previous version manually:
$ sudo pecl install mailparse-2.1.6

You can check all the releases version on this page:
 [2016-03-15 04:43 UTC]
-Assigned To: +Assigned To: seander
 [2016-03-15 04:43 UTC]
Thanks for answering this b.bellec!

I added a note on how to install older versions of mailparse to the PECL page. I need to follow up on getting pecl to install the newest compatible version, and no just bomb out.

 [2016-03-15 04:44 UTC]
-Status: Assigned +Status: Closed
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 19:01:29 2024 UTC