php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71298 MB_CASE_TITLE misbehaves with curled apostrophe/quote (HTML ’)
Submitted: 2016-01-07 02:51 UTC Modified: 2017-07-28 12:59 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: yohgaki@php.net Assigned: nikic (profile)
Status: Closed Package: mbstring related
PHP Version: 7.0Git-2016-01-07 (Git) OS: any
Private report: No CVE-ID: None
 [2016-01-07 02:51 UTC] yohgaki@php.net
Description:
------------
REF: https://bugs.php.net/bug.php?id=46607

This appears to be a duplicate of https://bugs.php.net/bug.php?id=36311

It was already fixed for straight apostrophe/quotes (HTML ') in https://bugs.php.net/bug.php?id=46626 but not for the curled apostrophe/quote (HTML ’) when using PHP 7.1.0-dev from git.

Reproduce code:
---------------

<?php
echo mb_convert_case("People's issues versus people’s issues", MB_CASE_TITLE);
?>

Expected result:
----------------

People's Issues Versus People’s Issues

Actual result:
--------------

People's Issues Versus People’S Issues


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-07-28 12:58 UTC] nikic@php.net
Automatic comment on behalf of nikita.ppv@gmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f4a1d9c8211fa7878af14d0bd94b2deaab19ae21
Log: Fixed bug #65544 and #71298
 [2017-07-28 12:59 UTC] nikic@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: nikic
 [2017-07-28 12:59 UTC] nikic@php.net
Fixed as part of bug #65544.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Dec 13 22:01:26 2018 UTC