php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71246 preg_replace failed with too long string
Submitted: 2015-12-30 15:37 UTC Modified: 2015-12-30 18:29 UTC
From: phpbug at lvht dot net Assigned:
Status: Not a bug Package: *Regular Expressions
PHP Version: 7.0.1 OS: mac, ubuntu 14.04
Private report: No CVE-ID: None
 [2015-12-30 15:37 UTC] phpbug at lvht dot net
Description:
------------
preg_replace anainst big string failed and preg_last_error() returns PREG_JIT_STACKLIMIT_ERROR

Test script:
---------------
<?php
$value = '{{--' . str_repeat('_', 1024). '--}}';

$pattern = '/{{--((.|\s)*?)--}}/';

var_dump(preg_replace($pattern, '+', $value));

Expected result:
----------------
+

Actual result:
--------------
NULL



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-30 18:29 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2015-12-30 18:29 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Your regex is not efficient enough to handle a string of that length. It needs to be optimized, such as by removing parentheses or using greedy quantifiers or using once-only subpatterns.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 03:03:34 2021 UTC