php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71211 ReflectionClass->isAbstract() returns false for traits
Submitted: 2015-12-24 11:32 UTC Modified: 2015-12-25 04:00 UTC
From: lisachenko dot it at gmail dot com Assigned:
Status: Not a bug Package: Reflection related
PHP Version: 7.0.1 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lisachenko dot it at gmail dot com
New email:
PHP Version: OS:

 

 [2015-12-24 11:32 UTC] lisachenko dot it at gmail dot com
Description:
------------
Looks like some constant values was changed in PHP7.0, after that ReflectionClass->isAbstract() for traits starts to return "false", whereas in earlier versions of PHP result was "true".

Test script:
---------------
<?php
// https://3v4l.org/5RF6l
trait Foo {}

$ref = new ReflectionClass('Foo');
var_dump($ref->isAbstract());

Expected result:
----------------
bool(true)

Actual result:
--------------
bool(false)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-25 04:00 UTC] laruence@php.net
-Status: Open +Status: Not a bug
 [2015-12-25 04:00 UTC] laruence@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

traits are not abstarct. the new behavior is better.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Sep 28 13:01:23 2020 UTC