php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #71177 add sha512/224 and sha512/256
Submitted: 2015-12-21 00:45 UTC Modified: 2016-05-14 04:40 UTC
From: zelnaga at gmail dot com Assigned: pollita (profile)
Status: Closed Package: hash related
PHP Version: 7.0.1 OS: Ubuntu
Private report: No CVE-ID: None
 [2015-12-21 00:45 UTC] zelnaga at gmail dot com
Description:
------------
According to http://php.net/manual/en/function.hash-algos.php sha512/224 and sha512/256 are not supported algorithms. They were initially defined FIPS 180-4 in March 2012:

https://www.federalregister.gov/articles/2012/03/06/2012-5400/announcing-approval-of-federal-information-processing-standard-fips-publication-180-4-secure-hash

sha224 and sha256 utilize 32-bit integers and process messages in 512-bit chunks.

sha384, sha512, sha512/224 and sha512/256 utilize 64-bit integers and process messages in 1024-bit chunks. The only difference between these four algorithms is that they have different initial values for the hash.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-21 01:00 UTC] zelnaga at gmail dot com
Also, see http://nvlpubs.nist.gov/nistpubs/FIPS/NIST.FIPS.180-4.pdf#page=35
 [2015-12-21 04:52 UTC] pajoye@php.net
-Status: Open +Status: Not a bug
 [2015-12-21 04:52 UTC] pajoye@php.net
They are, see

http://php.net/manual/en/function.hash-algos.php
    [4] => sha224
    [5] => sha256
    [6] => sha384
    [7] => sha512
 [2015-12-21 08:33 UTC] leigh@php.net
-Status: Not a bug +Status: Re-Opened
 [2015-12-21 08:33 UTC] leigh@php.net
@Pierre SHA-512/224 and SHA-512/256 are not the same as SHA-224 and SHA-256, so this is still a valid FR.
 [2016-05-14 04:06 UTC] pollita@php.net
-Assigned To: +Assigned To: pollita
 [2016-05-14 04:40 UTC] pollita@php.net
-Status: Re-Opened +Status: Closed
 [2016-05-14 04:40 UTC] pollita@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

https://github.com/php/php-src/commit/49a7be069700efbb98dbb076bb0891c748c343f4
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 08:03:36 2021 UTC