php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #71091 The extension does not work on PHP 7
Submitted: 2015-12-11 12:22 UTC Modified: 2016-03-14 14:11 UTC
Votes:12
Avg. Score:4.7 ± 0.7
Reproduced:12 of 12 (100.0%)
Same Version:12 (100.0%)
Same OS:11 (91.7%)
From: christiansen dot jacob at gmail dot com Assigned: ohill (profile)
Status: Closed Package: stem (PECL)
PHP Version: 7.0.0 OS: Ubuntu
Private report: No CVE-ID: None
 [2015-12-11 12:22 UTC] christiansen dot jacob at gmail dot com
Description:
------------
Trying to grab this extension via PECL yields the following output:

downloading stem-1.5.1.tgz ...
Starting to download stem-1.5.1.tgz (82,665 bytes)
....................done: 82,665 bytes
43 source files, building
running: phpize
Configuring for:
PHP Api Version:         20151012
Zend Module Api No:      20151012
Zend Extension Api No:   320151012
Compile Danish stemmer? [yes] : Compile Dutch stemmer? [yes] : Compile English stemmer? [yes] : Compile Finnish stemmer? [yes] : Compile French stemmer? [yes] : Compile German stemmer? [yes] : Compile Hungarian stemmer? [yes] : Compile Italian stemmer? [yes] : Compile Norwegian stemmer? [yes] : Compile Portuguese stemmer? [yes] : Compile Romanian stemmer? [yes] : Compile Russian stemmer? [yes] : Compile Russian (UTF8) stemmer? [yes] : Compile Spanish stemmer? [yes] : Compile Swedish stemmer? [yes] : Compile Turkish (UTF8) stemmer? [yes] : building in /tmp/pear/temp/pear-build-rootdM45ht/stem-1.5.1
running: /tmp/pear/temp/stem/configure --with-php-config=/usr/local/php70-debug/bin/php-config --enable-stem-danish=yes --enable-stem-dutch=yes --enable-stem-english=yes --enable-stem-finnish=yes --enable-stem-french=yes --enable-stem-german=yes --enable-stem-hungarian=yes --enable-stem-italian=yes --enable-stem-norwegian=yes --enable-stem-portuguese=yes --enable-stem-romanian=yes --enable-stem-russian=yes --enable-stem-russian_unicode=yes --enable-stem-spanish=yes --enable-stem-swedish=yes --enable-stem-turkish_unicode=yes
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr/local/php70-debug
checking for PHP includes... -I/usr/local/php70-debug/include/php -I/usr/local/php70-debug/include/php/main -I/usr/local/php70-debug/include/php/TSRM -I/usr/local/php70-debug/include/php/Zend -I/usr/local/php70-debug/include/php/ext -I/usr/local/php70-debug/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/php70-debug/lib/php/extensions/debug-non-zts-20151012
checking for PHP installed headers prefix... /usr/local/php70-debug/include/php
checking if debug is enabled... yes
checking if zts is enabled... no
checking for re2c... re2c
checking for re2c version... 0.13.5 (ok)
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking whether to enable stem support... yes, shared
checking whether to compile Danish stemmer... yes
checking whether to compile Dutch stemmer... yes
checking whether to compile English (non Porter) stemmer... yes
checking whether to compile French stemmer... yes
checking whether to compile Finnish stemmer... yes
checking whether to compile German stemmer... yes
checking whether to compile Hungarian stemmer... yes
checking whether to compile Italian stemmer... yes
checking whether to compile Norwegian stemmer... yes
checking whether to compile Portuguese stemmer... yes
checking whether to compile Romanian stemmer... yes
checking whether to compile Russian stemmer... yes
checking whether to compile Russian (UTF8) stemmer... yes
checking whether to compile Spanish stemmer... yes
checking whether to compile Swedish stemmer... yes
checking whether to compile Turkish (UTF8) stemmer... yes
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 1572864
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/bash /tmp/pear/temp/pear-build-rootdM45ht/stem-1.5.1/libtool --mode=compile cc  -I. -I/tmp/pear/temp/stem -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-rootdM45ht/stem-1.5.1/include -I/tmp/pear/temp/pear-build-rootdM45ht/stem-1.5.1/main -I/tmp/pear/temp/stem -I/usr/local/php70-debug/include/php -I/usr/local/php70-debug/include/php/main -I/usr/local/php70-debug/include/php/TSRM -I/usr/local/php70-debug/include/php/Zend -I/usr/local/php70-debug/include/php/ext -I/usr/local/php70-debug/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O0   -c /tmp/pear/temp/stem/stem.c -o stem.lo
mkdir .libs
 cc -I. -I/tmp/pear/temp/stem -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-rootdM45ht/stem-1.5.1/include -I/tmp/pear/temp/pear-build-rootdM45ht/stem-1.5.1/main -I/tmp/pear/temp/stem -I/usr/local/php70-debug/include/php -I/usr/local/php70-debug/include/php/main -I/usr/local/php70-debug/include/php/TSRM -I/usr/local/php70-debug/include/php/Zend -I/usr/local/php70-debug/include/php/ext -I/usr/local/php70-debug/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O0 -c /tmp/pear/temp/stem/stem.c  -fPIC -DPIC -o .libs/stem.o
/tmp/pear/temp/stem/stem.c: In function ‘php_stem’:
/tmp/pear/temp/stem/stem.c:222:37: error: macro "RETURN_STRINGL" passed 3 arguments, but takes just 2
   RETURN_STRINGL(incoming, arglen, 1);
                                     ^
/tmp/pear/temp/stem/stem.c:222:3: error: ‘RETURN_STRINGL’ undeclared (first use in this function)
   RETURN_STRINGL(incoming, arglen, 1);
   ^
/tmp/pear/temp/stem/stem.c:222:3: note: each undeclared identifier is reported only once for each function it appears in
/tmp/pear/temp/stem/stem.c:339:30: error: macro "RETVAL_STRINGL" passed 3 arguments, but takes just 2
  RETVAL_STRINGL(z->p, z->l, 1);
                              ^
/tmp/pear/temp/stem/stem.c:339:2: error: ‘RETVAL_STRINGL’ undeclared (first use in this function)
  RETVAL_STRINGL(z->p, z->l, 1);
  ^
Makefile:193: recipe for target 'stem.lo' failed
make: *** [stem.lo] Error 1
ERROR: `make' failed





Patches

feature-support-php5-and-php7 (last revision 2016-03-07 16:01 UTC by nikitin dot dv27 at gmail dot com)
feature-support-php7 (last revision 2016-03-01 12:18 UTC by nikitin dot dv27 at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-19 01:31 UTC] ajf@php.net
-Type: Bug +Type: Feature/Change Request
 [2015-12-30 17:21 UTC] ohill@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: ohill
 [2015-12-30 17:21 UTC] ohill@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.
 [2015-12-30 17:23 UTC] ohill@php.net
-Status: Closed +Status: Re-Opened
 [2016-03-14 14:10 UTC] ohill@php.net
Automatic comment from SVN on behalf of ohill
Revision: http://svn.php.net/viewvc/?view=revision&revision=338739
Log: Fix for bug #71091 with modified patch from nikitin
 [2016-03-14 14:11 UTC] ohill@php.net
-Status: Re-Opened +Status: Closed
 [2016-03-14 14:11 UTC] ohill@php.net
Please try code available on SVN.

The patch didn't apply, had to modify it to fit what was on SVN.
 [2016-03-21 10:21 UTC] christiansen dot jacob at gmail dot com
Seems to be working as expected on PHP 7. 

Thank you. When will it be released??
 [2016-12-07 08:29 UTC] christiansen dot jacob at gmail dot com
Will the package stem be released in a new version in PECL for use with PHP7??
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Oct 16 15:01:26 2019 UTC