php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71011 Segmentation fault with AMQP extension
Submitted: 2015-12-01 21:53 UTC Modified: 2015-12-28 02:11 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:2 (100.0%)
From: saschaprolic at googlemail dot com Assigned:
Status: Closed Package: amqp (PECL)
PHP Version: 5.6.16 OS: Ubuntu 15.10
Private report: No CVE-ID: None
 [2015-12-01 21:53 UTC] saschaprolic at googlemail dot com
Description:
------------
Bug appears in 5.6.15 & 5.6.16.
5.6.11 however is good!

I could not yet isolate the bug, but can show how to reproduce it.

Steps to reproduce:

git clone https://github.com/zendframework/ZendSkeletonApplication
cd ZendSkeletonApplication
composer install
composer require prolic/humus-supervisor-module dev-master
composer require prolic/humus-amqp-demo-module v0.1.1

vi config/application.config.php
add to your module's array:

'HumusAmqpModule',
'HumusAmqpDemoModule',

php public/index.php humus amqp setup-fabric

Output:
Setting up the AMQP fabric
Declaring exchanges ...
Declaring queues ...
[1]    15474 segmentation fault (core dumped)

Backtrace:
#0  _zend_mm_free_int (heap=0x135c940, p=0x1aa4978) at /home/sasa/Downloads/php-5.6.16/Zend/zend_alloc.c:2104
#1  0x0000000000870697 in zend_object_std_dtor (object=0x1adc620, tsrm_ls=<optimized out>) at /home/sasa/Downloads/php-5.6.16/Zend/zend_objects.c:54
#2  0x00000000008706c9 in zend_objects_free_object_storage (object=0x1adc620, tsrm_ls=<optimized out>)
    at /home/sasa/Downloads/php-5.6.16/Zend/zend_objects.c:137
#3  0x0000000000877596 in zend_objects_store_del_ref_by_handle_ex (handle=<optimized out>, handlers=<optimized out>, tsrm_ls=tsrm_ls@entry=0x135c3a0)
    at /home/sasa/Downloads/php-5.6.16/Zend/zend_objects_API.c:226
#4  0x00000000008775ee in zend_objects_store_del_ref (zobject=0x1ae3750, tsrm_ls=0x135c3a0)
    at /home/sasa/Downloads/php-5.6.16/Zend/zend_objects_API.c:178
#5  0x00000000008baa62 in _zval_dtor (zvalue=0x1ae3750) at /home/sasa/Downloads/php-5.6.16/Zend/zend_variables.h:35
#6  zend_assign_to_variable (tsrm_ls=0x135c3a0, value=0x17c9c88, variable_ptr_ptr=0x7f8a708bafc0)
    at /home/sasa/Downloads/php-5.6.16/Zend/zend_execute.c:922
#7  ZEND_ASSIGN_SPEC_CV_VAR_HANDLER (execute_data=0x7f8a708baec0, tsrm_ls=0x135c3a0) at /home/sasa/Downloads/php-5.6.16/Zend/zend_vm_execute.h:37468
#8  0x000000000088754b in execute_ex (execute_data=0x7f8a708baec0, tsrm_ls=0x135c3a0) at /home/sasa/Downloads/php-5.6.16/Zend/zend_vm_execute.h:363
#9  0x0000000000834fb6 in zend_call_function (fci=fci@entry=0x7ffcc0819960, fci_cache=<optimized out>, fci_cache@entry=0x7ffcc0819930, 
    tsrm_ls=tsrm_ls@entry=0x135c3a0) at /home/sasa/Downloads/php-5.6.16/Zend/zend_execute_API.c:829
#10 0x0000000000714e0c in zif_call_user_func (ht=<optimized out>, return_value=0x198a3a0, return_value_ptr=<optimized out>, this_ptr=<optimized out>, 
    return_value_used=<optimized out>, tsrm_ls=0x135c3a0) at /home/sasa/Downloads/php-5.6.16/ext/standard/basic_functions.c:4759
#11 0x000000000090091e in zend_do_fcall_common_helper_SPEC (execute_data=<optimized out>, tsrm_ls=0x135c3a0)
    at /home/sasa/Downloads/php-5.6.16/Zend/zend_vm_execute.h:558
#12 0x000000000088754b in execute_ex (execute_data=0x7f8a708b9880, tsrm_ls=0x135c3a0) at /home/sasa/Downloads/php-5.6.16/Zend/zend_vm_execute.h:363
#13 0x000000000084767c in zend_execute_scripts (type=type@entry=8, tsrm_ls=tsrm_ls@entry=0x135c3a0, retval=retval@entry=0x0, 
    file_count=file_count@entry=3) at /home/sasa/Downloads/php-5.6.16/Zend/zend.c:1341
#14 0x00000000007d428a in php_execute_script (primary_file=primary_file@entry=0x7ffcc081bfe0, tsrm_ls=tsrm_ls@entry=0x135c3a0)
    at /home/sasa/Downloads/php-5.6.16/main/main.c:2597
#15 0x00000000009026f6 in do_cli (argc=5, argv=0x135c300, tsrm_ls=0x135c3a0) at /home/sasa/Downloads/php-5.6.16/sapi/cli/php_cli.c:994
#16 0x0000000000434254 in main (argc=5, argv=0x135c300) at /home/sasa/Downloads/php-5.6.16/sapi/cli/php_cli.c:1378


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-01 21:57 UTC] saschaprolic at googlemail dot com
5.6.09 and 5.6.13 seems to be good as well (tested on other machines).
 [2015-12-28 02:11 UTC] saschaprolic at googlemail dot com
-Status: Open +Status: Closed
 [2015-12-28 02:11 UTC] saschaprolic at googlemail dot com
This is a bug in ext-amqp which is solved here: https://github.com/pdezwart/php-amqp/issues/195
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Aug 06 03:01:24 2021 UTC