php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70878 Cached files have weird characters
Submitted: 2015-11-07 22:32 UTC Modified: 2015-11-08 13:10 UTC
From: nfuzedean at gmail dot com Assigned:
Status: Closed Package: opcache
PHP Version: 7.0.0RC6 OS: CentOS 7
Private report: No CVE-ID: None
 [2015-11-07 22:32 UTC] nfuzedean at gmail dot com
Description:
------------
I tried running IPS 4.1 which works fine except for when using opcache.
When using opcache I get php errors, looking at the error log I see things like this: [07-Nov-2015 21:55:38 UTC] PHP Fatal error:  Class 'IPS\Node\ModelØ”^A' not found in forum/system/Lang/Lang.php on line 24

Notice the '^A', there seems to be an error caching the files.

I used http://centminmod.com/ 123.09beta01 with the default settings, you should be able to reproduce it by using it.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-11-08 03:14 UTC] laruence@php.net
-Status: Open +Status: Feedback
 [2015-11-08 03:14 UTC] laruence@php.net
Please try using this snapshot:

  http://snaps.php.net/php-trunk-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/

I fixed a literal bug recently, maybe you could try with the latest snapshot ?
 [2015-11-08 10:14 UTC] nfuzedean at gmail dot com
Hello,

I would but I cannot seem to be able to access the snap.

wget http://snaps.php.net/php-trunk-latest.tar.gz
--2015-11-08 10:07:39--  http://snaps.php.net/php-trunk-latest.tar.gz
Resolving snaps.php.net (snaps.php.net)... 104.236.26.243, 2604:a880:800:10::2e6:c001
Connecting to snaps.php.net (snaps.php.net)|104.236.26.243|:80... failed: Connection refused.
Connecting to snaps.php.net (snaps.php.net)|2604:a880:800:10::2e6:c001|:80... failed: Network is unreachable.
 [2015-11-08 13:10 UTC] nfuzedean at gmail dot com
-Status: Feedback +Status: Closed
 [2015-11-08 13:10 UTC] nfuzedean at gmail dot com
Downloaded latest snapshot from github and this seems to be fixed!
Thanks @laruence!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 26 14:01:28 2020 UTC