php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70840 timezone_identifiers_list() shows wrong city names for Ukraine
Submitted: 2015-11-02 16:52 UTC Modified: 2016-05-29 20:53 UTC
Votes:4
Avg. Score:2.8 ± 1.5
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: serhiy dot shkolyarenko at gmail dot com Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 7.0.0RC6 OS: any
Private report: No CVE-ID: None
 [2015-11-02 16:52 UTC] serhiy dot shkolyarenko at gmail dot com
Description:
------------
Method DateTimeZone::listIdentifiers(DateTimeZone::EUROPE, 'UA') shows Ukrainian cities transliterated from russian, not from ukrainian, so it doesn't correspond official names.

Error is spotted for Kyiv(http://www.local-life.com/kiev/articles/kiev-or-kyiv) and Zaporizhia(https://en.wikipedia.org/wiki/Zaporizhia). Uzhgorod and Simferopol are OK because have the same transliteration for russian and ukrainian.

Checked for PHP versions 5.6.11 and 7.0.0-RC6.

Test script:
---------------
var_dump(DateTimeZone::listIdentifiers(DateTimeZone::EUROPE, 'UA'));

Expected result:
----------------
...
Europe/Kyiv
...
Europe/Zaporizhia

Actual result:
--------------
...
Europe/Kiev
...
Europe/Zaporozhye

Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-11-05 19:35 UTC] marcosptf at yahoo dot com dot br
hello to everyone!

i've trying to resolve this bug, i did a PR to github, i don't know if correct, but to my mind this is way and i did first in my computer before commit.

let's waint someone answer the PR to see, whats the next steps!
 [2015-11-05 23:14 UTC] rasmus@php.net
-Status: Open +Status: Analyzed
 [2015-11-05 23:14 UTC] rasmus@php.net
Fixing this in PHP doesn't really help since we just use the IANA database. Next time we sync with the upstream release your changes will disappear. If you want this changed you should head over to http://www.iana.org/time-zones and file an issue with them. However, in the file you find there you will see this:

# Zaporozh'ye and eastern Lugansk oblasts observed DST 1990/1991.
# "Zaporizhia" is the transliteration of the Ukrainian name, but
# "Zaporozh'ye" is more common in English.  Use the common English
# spelling, except omit the apostrophe as it is not allowed in
# portable Posix file names.
Zone Europe/Zaporozhye  2:20:40 -   LMT 1880
            2:20    -   CUT 1924 May  2 # Central Ukraine T
            2:00    -   EET 1930 Jun 21
            3:00    -   MSK 1941 Aug 25
            1:00    C-Eur   CE%sT   1943 Oct 25
            3:00    Russia  MSK/MSD 1991 Mar 31  2:00
            2:00    E-Eur   EE%sT   1995
            2:00    EU  EE%sT

So someone has thought about this and deliberately chose to call it Zaporozhye

We really don't want to divert from the official IANA designated identifiers as these are used by pretty much everything.
 [2015-11-07 16:30 UTC] marcosptf at yahoo dot com dot br
i think that Rasmus is right, is not intesting the php-src is divert from IANA.

:D
 [2016-05-29 20:53 UTC] ab@php.net
-Status: Analyzed +Status: Not a bug
 [2016-05-29 20:53 UTC] ab@php.net
Closing as it's not applicable.

Thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 18 18:01:27 2020 UTC