php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70831 Compile fails on system with 160 CPUs
Submitted: 2015-11-01 23:33 UTC Modified: -
Votes:2
Avg. Score:3.0 ± 2.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: dja at axtens dot net Assigned:
Status: Closed Package: Compile Failure
PHP Version: master-Git-2015-11-01 (Git) OS: Linux
Private report: No CVE-ID:
 [2015-11-01 23:33 UTC] dja at axtens dot net
Description:
------------
I'm compiling PHP in a Docker container on a POWER8 machine with 160 hardware threads. I am consistently hitting the following failure:

ext/tokenizer/tokenizer_data.c:28:34: fatal error: zend_language_parser.h: No such file or directory
 #include <zend_language_parser.h>
                                  ^
compilation terminated.

This can be fixed by making tokenizer_data.c depend on zend_language_parser.h. I am attaching a pull request to that effect.

My guess is that this isn't seen more broadly because it requires a massively parallel compile to hit the case tokenizer_data is build before the parser header is generated.


Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-06 11:43 UTC] ab@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=713ad54fec5e54fd6295902c03497664f4aa62b1
Log: update NEWS with fixed bug #70831
 [2015-12-06 11:43 UTC] ab@php.net
-Status: Open +Status: Closed
 [2015-12-06 11:43 UTC] ab@php.net
Automatic comment on behalf of dja@axtens.net
Revision: http://git.php.net/?p=php-src.git;a=commit;h=2ea924fffcb1ed63af6d68560a4930881f4e8ab1
Log: Fix #70831: Compile fails on system with 160 CPUs
 [2016-07-20 11:35 UTC] davey@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=713ad54fec5e54fd6295902c03497664f4aa62b1
Log: update NEWS with fixed bug #70831
 [2016-07-20 11:35 UTC] davey@php.net
Automatic comment on behalf of dja@axtens.net
Revision: http://git.php.net/?p=php-src.git;a=commit;h=2ea924fffcb1ed63af6d68560a4930881f4e8ab1
Log: Fix #70831: Compile fails on system with 160 CPUs
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Thu Jul 20 18:01:35 2017 UTC