php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70823 Array in Class definition has a limit
Submitted: 2015-10-30 20:50 UTC Modified: 2015-10-30 22:08 UTC
From: jelte at khepri dot be Assigned:
Status: Duplicate Package: Class/Object related
PHP Version: 5.6.15 OS: Mac OSX, Linux
Private report: No CVE-ID: None
 [2015-10-30 20:50 UTC] jelte at khepri dot be
Description:
------------
When creating a class with a static array property of 32769 elements, the static array only has 1 element when calling the static property.

When creating the array in the constructor the result is as expected.

Test script below is a simplification of the route caching of Symfony where we noticed this problem.

We have test this in php 5.5, where we get the expected result.

Test script:
---------------
https://gist.github.com/jelte/b2a9d73aec0211b07f6e

Expected result:
----------------
32769 routes in class

Actual result:
--------------
1 routes in class

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-10-30 22:08 UTC] bwoebi@php.net
-Status: Open +Status: Duplicate
 [2015-10-30 22:08 UTC] bwoebi@php.net
Duplicate of #68057
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 20:03:34 2021 UTC