php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70821 Phar depends on ext/hash to be built
Submitted: 2015-10-30 10:14 UTC Modified: 2015-10-30 10:30 UTC
From: bwoebi@php.net Assigned:
Status: Not a bug Package: PHAR related
PHP Version: master-Git-2015-10-30 (Git) OS: Irrelevant
Private report: No CVE-ID: None
 [2015-10-30 10:14 UTC] bwoebi@php.net
Description:
------------
Can we please add a compile time check, ifdefs or move the problematic hash functions somewhere else in order to build phar standalone (or in case of compile time check, notify the user what's wrong). A list of undefined symbols doesn't help...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-10-30 10:26 UTC] bwoebi@php.net
Same for ext/session for php_hash_fetch_ops symbol
 [2015-10-30 10:29 UTC] bwoebi@php.net
Oops, the latter is a false positive… Just hadn't make clean first.
 [2015-10-30 10:30 UTC] bwoebi@php.net
-Status: Open +Status: Not a bug
 [2015-10-30 10:30 UTC] bwoebi@php.net
I shouldn't forget to make clean when doing a reconfigure …
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 08:03:36 2021 UTC