php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70775 libmysqlclient20
Submitted: 2015-10-23 11:36 UTC Modified: 2015-10-31 18:27 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: czarnoski at seitenreport dot info Assigned: mysql (profile)
Status: Not a bug Package: MySQL related
PHP Version: 7.0.0RC5 OS: Ubuntu 15.04
Private report: No CVE-ID: None
 [2015-10-23 11:36 UTC] czarnoski at seitenreport dot info
Description:
------------
I installed Mysql 5.7.9 with mysql-config.
This makes an overwrite from libmysqlclient18 to libmysqlclient20.

The effect - apache does not restart because php 7 cannot load libmysqlclient18.

After install libmysqlclient18 additional php7 works but mysql 5.7.9 needs libmysqlclient20.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-10-30 17:37 UTC] kalle@php.net
-Status: Open +Status: Assigned -Package: *General Issues +Package: MySQL related -Assigned To: +Assigned To: mysql
 [2015-10-30 17:37 UTC] kalle@php.net
Passing this on to the MySQL team, maybe they can shed some light on this
 [2015-10-31 18:27 UTC] johannes@php.net
-Status: Assigned +Status: Not a bug
 [2015-10-31 18:27 UTC] johannes@php.net
If I understand cirrectly you replaced a library provided by the system with a newer version. If thus is true you can expect all programs depending in it to break. If you installed via apt/deb there should have been a warning. You shouldn't overwrite system libraries. Please refer to your system's documentation to repair this.

You can install MySQL 5.7 and its libraries next to older versions. Refer to MySQL documentation for that.

You don't need a new client library with a new server. The network protocol is backwards compatible. But for PHP usage of mysqlnd is suggested. For Debian there is a php5-mysqlnd package, which can be installed instead of php5-mysql.

This issue seems to be a misconfiguration of the system. No bug.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 19:04:05 2022 UTC