php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70721 2015.7 x86 DLL not compatible PHP 7.0 RC5
Submitted: 2015-10-15 17:44 UTC Modified: 2015-10-15 18:35 UTC
From: pear at laurent-laville dot org Assigned: ab (profile)
Status: Not a bug Package: timezonedb (PECL)
PHP Version: 7.0.0RC5 OS: Windows
Private report: No CVE-ID: None
 [2015-10-15 17:44 UTC] pear at laurent-laville dot org
Description:
------------
New RC5 of PHP 7.0 has just been released, and I got error with PHP 7.0 x86 DLL, while all was correct with previous RC4.



Expected result:
----------------
No warning when invoking php -v command

Actual result:
--------------
C:\UwAmp\bin\php\php-7.0.0>php -v

Warning: PHP Startup: timezonedb: Unable to initialize module
Module compiled with module API=20141001
PHP    compiled with module API=20151012
These options need to match
 in Unknown on line 0
PHP 7.0.0RC5 (cli) (built: Oct 14 2015 17:11:33) ( ZTS )
Copyright (c) 1997-2015 The PHP Group
Zend Engine v3.0.0-dev, Copyright (c) 1998-2015 Zend Technologies

C:\UwAmp\bin\php\php-7.0.0>php --ri date

Warning: PHP Startup: timezonedb: Unable to initialize module
Module compiled with module API=20141001
PHP    compiled with module API=20151012
These options need to match
 in Unknown on line 0

date

date/time support => enabled
"Olson" Timezone Database Version => 2015.7
Timezone Database => internal
Default timezone => Europe/Paris

Directive => Local Value => Master Value
date.timezone => Europe/Paris => Europe/Paris
date.default_latitude => 31.7667 => 31.7667
date.default_longitude => 35.2333 => 35.2333
date.sunset_zenith => 90.583333 => 90.583333
date.sunrise_zenith => 90.583333 => 90.583333

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-10-15 18:34 UTC] ab@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: ab
 [2015-10-15 18:34 UTC] ab@php.net
Thanks for the report. RC5 already contains the timezone db 2015.7 bundled. Rebuilding the existing DLL for RC5 compatibility will bring no benefit but make it incompatible with RC4 and earlier.

Thanks.
 [2015-10-15 18:35 UTC] ab@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Aug 20 00:01:27 2019 UTC