php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70665 invalid pointer: 0x00007f6a283ff0e0
Submitted: 2015-10-08 01:08 UTC Modified: 2017-01-15 06:59 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: admin at thecustomizewindows dot com Assigned:
Status: Wont fix Package: FPM related
PHP Version: 5.5Git-2015-10-08 (Git) OS: Ubuntu 14.04.3 LTS
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2015-10-08 01:08 UTC] admin at thecustomizewindows dot com
Description:
------------
It is opened as bug for possible future reference only. It occurred after running command to get php-apc installed after enabling Zend OpCache from php.ini for emulation of our one blog reader's problem.  Other packages were -  php5-xcache and php5-apcu. php -v command vanished xcache's name in output and zend opcache pointed towards an invalid pointer error.

We have added a PHP script to get 500 internal server error. Setup with such wrong steps will work fine, but possibly it is a risk to allow such unnoticed error.


Unexpected output :

##############

root@4gbtcw:/home/ubuntu# php -v
PHP Warning:  Module 'Zend OPcache' already loaded in Unknown on line 0
PHP Warning:  Zend OPcache: module registration failed! in Unknown on line 0
PHP 5.5.9-1ubuntu4.13 (cli) (built: Sep 29 2015 15:24:49)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies
*** Error in `php': free(): invalid pointer: 0x00007fb8003ff0e0 ***
Aborted (core dumped)

##############

Test script:
---------------
repo has test.php file and backtrace - https://github.com/AbhishekGhosh/invalid-pointer-0x00007f75ec3ff0e0

Expected result:
----------------
test.php will show 500 internal server error on curl. 

Actual result:
--------------
Above URL of the repo has detailed output. Possibly not required unless demanded for finding any security flaw. 
OpenStack snapshot of the instance with the issue can be asked from us - https://thecustomizewindows.com/

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-10-08 08:36 UTC] admin at thecustomizewindows dot com
I reproduced it by installing php5-apcu & php5-xcache.  
php5-apcu should have a warning for conflict with php5-xcache (php-apc has warning). Package maintainer(s) will be informed.
 [2017-01-15 06:59 UTC] krakjoe@php.net
-Status: Open +Status: Wont fix
 [2017-01-15 06:59 UTC] krakjoe@php.net
This appears to be a downstream (package maintenance) problem.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC